• Play
  • About
  • News
  • Forums
  • Yppedia
  • Help
Welcome Guest   | Login
  Index  | Recent Threads  | Register  | Search  | Help  | RSS feeds  | View Unanswered Threads  
  Search  


Quick Go »
Thread Status: Normal
Total posts in this thread: 11
[Add To My Favorites] [Watch this Thread] [Post new Thread]
Author
Previous Thread This topic has been viewed 6960 times and has 10 replies Next Thread
CraftingProj

Member's Avatar


Joined: Sep 21, 2006
Posts: 221
Status: Offline
Game Gardens troubleshooting Reply to this Post
Reply with Quote

If you are having trouble getting the puzzles to work in GameGardens, here are some things to try.

1. Click the "Play" link, not the "Play in applet" link. Most of the puzzles do not work correctly in applet mode.

2. Download the latest Java JRE from this website . If it asks if you want Java WebStart, say yes. We need Java WebStart to run the GameGardens games not in applet mode.

If you still can't log in at all, and you have verified that you have internet access, at one time players were having problems with the JAR files not downloading. Clearing your browser's cache (temporary internet files) helped sometimes with that problem. If you still have trouble, please post here giving as much detail as possible about the problem you are having, and we will try to find some advice for you.
[Jan 2, 2007 4:42:21 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Patetch

Member's Avatar


Joined: Apr 22, 2006
Posts: 3340
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

Ah - thank you - redownloading Java did the trick - I hadn't tried that before because I wasn't having problems with Java anywhere else.
I am assuming that everyone is welcome to give feedback, not just those who volunteered earlier. I have read over the posts and I think I have a pretty good grasp of what you are looking for here.
----------------------------------------
Pletoo of Sage
[Jan 2, 2007 5:38:28 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
CraftingProj

Member's Avatar


Joined: Sep 21, 2006
Posts: 221
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

Yes, everybody is encouraged to give feedback.
[Jan 2, 2007 6:46:20 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Patetch

Member's Avatar


Joined: Apr 22, 2006
Posts: 3340
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

Another note concerning Game Gardens: Sometimes I am in the lobby for a minute or two before the Create Table button pops up, so if you find that nothing happens when you click on a game, just wait a bit and see if it comes up.
----------------------------------------
Pletoo of Sage
[Jan 3, 2007 2:00:04 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
gldnstern



Joined: Aug 5, 2005
Posts: 239
Status: Offline

Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

I had no problem playing several of the other GCPP games this morning, but when I try to start a Haddock game now, it kicks me back to the login screen. I'm not trying to play in the applet, and I get to the game options screen just fine, but when I 'create table' it boots me out. This happens whether or not there is another game currently being played.
[Jan 5, 2007 5:48:57 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
tcarr

Member's Avatar


Joined: Jun 7, 2004
Posts: 4294
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

Have you played Haddock before (successfully)? When I try to play, I get a security alert asking if it's ok for the game to establish a connection with (some other website). I have to say yes in order to continue. If your browser doesn't give you that option, it might mean your security is preventing something from loading that the game needs.
----------------------------------------
LordKalvan of Otherwhen, all oceans but mostly Midnight
[Jan 5, 2007 5:59:04 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
McGarvery

Member's Avatar


Joined: Feb 11, 2006
Posts: 1525
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

I've got my package downloaded and running, but for some confounded reason my server is not talking to my client.
They seem to be acknowledging one another, but I can't reach the Lobby.

Any suggestions?
[Jun 26, 2007 10:19:06 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
tcarr

Member's Avatar


Joined: Jun 7, 2004
Posts: 4294
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

Are you trying to play games on Game Gardens, or trying to code your own game and test it locally?
----------------------------------------
LordKalvan of Otherwhen, all oceans but mostly Midnight
[Jun 27, 2007 3:36:45 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
McGarvery

Member's Avatar


Joined: Feb 11, 2006
Posts: 1525
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

 
Are you trying to play games on Game Gardens, or trying to code your own game and test it locally?

It's a local test that is failing.
[Jun 27, 2007 4:32:24 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
McGarvery

Member's Avatar


Joined: Feb 11, 2006
Posts: 1525
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

Here is a log of the the most recent attempt, post-Java update.

Upon running the server, I was prompted to unblock it by XP firewall, and I did.

Here is the more tasty bits of INFO from Server and Client sides...
Maybe the WARNINGS that appear in the logs will provide a clue as to why I cannot get to the Lobby.

SERVER ACTIVITY

com.threerings.presents.Log.info: Server listening on 0.0.0.0/0.0.0.0:47624
com.threerings.presents.server.DummyAuthenticator.processAuthentication:accepting request: [type=AREQ, msgid=1, creds=[username=kelly, password=((encrypted))], version=]
com.threerings.presents.log.info: Session initiated [username=kelly, conn=[mode=RUNNING, id=507, addr=/127.0.0.1]].

WARNING Log.warning: Invocation unit failed [unit=resolveLobby(-1)]
WARNING Log.logStackTrace : null
java.lang.NullPointerException
at com.threerings.toybox.server.ToyBoxManager$3.invoke(ToyBoxManager.java:284_
at com.samskivert.util.Invoker.iterate(Invoker.java:134)
at com.samskivert.util.LoopingThread.run(LoopingThread.java:76)

(After about 10 minutes...)
~ CTRL+C
----
CLIENT ACTIVITY


Client failed to load 'unsafe' library: java.lang.UnsatisfiedLinkError: no unsafe in java.library.path
Connecting [host=localhost/127.0.0.1, port= ((Port))
client.ClientController.clientDidLogon: Client did logon [client=com.threerings.presents.client.Client@((Serial])).
com.threerings.util.IdleTracker.checkIdle: User idle for 212738 ms.
client.ToyBoxClient$1.updateIdle: setting idle true

((glancing at window upon a change))

client.ToyBoxClient$1.updateIdle: Setting idle false.

((At CTRL+C))

com.threerings.presents.Log.info: Connection failed: java.io.IOException: An existing connection was forcibly closed by the remote host

Following, a string of warnings probably caused by the abrupt end to the connection.
[Jun 27, 2007 4:53:06 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
McGarvery

Member's Avatar


Joined: Feb 11, 2006
Posts: 1525
Status: Offline
Re: Game Gardens troubleshooting Reply to this Post
Reply with Quote

Persistence wins. I had a bad build, and started from scratch and this time the thing flew.

Bye to silly problem... we proceed.
[Jun 27, 2007 5:04:20 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
[Show Printable Version of Thread] [Post new Thread]

Puzzle Pirates™ © 2001-2016 Grey Havens, LLC All Rights Reserved.   Terms · Privacy · Affiliates