mvnForum Homepage

Print at Jan 22, 2021 8:59:25 AM

Posted by benlie at Apr 13, 2017 10:21:06 AM
DPI Upscaling 200% From 1080 to 4k No Longer Works After Update

I haven't logged on for a little over a week, and after logging on and updating the game yesterday, I have been unable to upscale my game through Window 10's DPI upscaling from 1080 resolution to 4k.

In the past, I had my Steam version's "javaw" file's properties set to run as Administrator, with the "Disable DPI Scaling" option uncheck (so it would upscale), as well as Compatibility mode set to Windows XP Service Pack 2. With the game client set to 1080 resolution windowed mode, this would allow me to comfortably play at an upscaled 4k client size, with all UI upscaled appropriately.

After the update, however, the client only starts with a blank white screen and seems to freeze. Only by settings "javaw" to disable DPI scaling does it work. I have tried all the compatibility modes (Windows XP, 7, 8, etc.) and without compatibility, yet the problem persists so long as DPI scaling is enabled.

1080 resolution unscaled on my 4k monitor is unplayably small. I saw in the update's notes that the game client's 4k resolution setting had been made to have the UI scale itself, but setting the game client to 4k had the same small UI problems as before the update.

I have tried uninstalled and reinstalling both Java and YPP to no avail.
As it stands now, I can't play the game unless I have DPI scaling unchecked, leading to unbearably small client resolutions or UI.

Puzzle Pirates™ © 2001-2020 Grey Havens, LLC All Rights Reserved.   Terms · Privacy · Affiliates