• Play
  • About
  • News
  • Forums
  • Yppedia
  • Help
Welcome Guest   | Login
  Index  | Recent Threads  | Register  | Search  | Help  | RSS feeds  | View Unanswered Threads  
  Search  


Quick Go »
Thread Status: Normal
Thread Type: Sticky Thread
Total posts in this thread: 83
Posts: 83   Pages: 3   [ First Page | Previous Page | 1 2 3 | Last Page]
[Add To My Favorites] [Watch this Thread] [Post new Thread]
Author
Previous Thread This topic has been viewed 50289 times and has 82 replies Next Thread
LJAmethyst

Member's Avatar


Joined: Jul 19, 2007
Posts: 3966
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

I have heard no reports of the compatibility or suitability of Java SE 8 with the Puzzle Pirates client. I would still recommend that where possible, people continue to use Java SE 7 until compatibility can be worked out.
----------------------------------------
Retired as of August 2015.
2 Timothy 4:7
[Nov 29, 2014 9:39:00 AM] Show Printable Version of Post        Send Private Message    http://www.newadvent.org/bible/jon001.htm [Link]  Go to top 
Opsat



Joined: May 20, 2007
Posts: 125
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

Came here to see if anyone is having the same problem as mine. About a week ago, everything was fine. But when I tried opening my client today, I couldn't make it work. Am experiencing the exact same thing bethieboo described:

 

Java Virtual Machine Launcher
Error: Registry key 'Software\JavaSoft\Java Runtime Environment'\CurrentVersion' has value '1.8', but '1.7' is required.

Java Virtual Machine Launcher
Error: could not find java.dll

Java Virtual Machine Launcher
Error: Could not find Java SE Runtime Enivronment



Not sure if I updated Java since I last logged in. Maybe I did.
Going to try the client from the site but it is still downloading data as of this post.
But I do hope I'll be able to use the one from my desktop in the future...
----------------------------------------
Opsat on all oceans.
(Also Opsat-East on Emerald and Meridian, and Opsat-West on Cerulean.)
And on Obsidian: Opsat, Meghost, and Meshadow.
[Jan 24, 2015 3:10:59 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
bethieboo

Member's Avatar


Joined: Dec 29, 2005
Posts: 696
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

I got another Java update prompt the other day and just got around to testing the YPP client today- the newest update allows me back on the client. If you're having trouble with the game check to see if it's truly the latest version.
----------------------------------------
Sera/phie
 
Yassenn says, "you'd be surprised, i made this really cool spreadsheet a week or two ago"

Avi by Wayfarer
[Jan 25, 2015 4:19:01 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Frouke



Joined: Dec 16, 2013
Posts: 31
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

Having exact same problem did you manage to resolve it?
[Jan 30, 2015 6:36:41 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
cracklow



Joined: Feb 20, 2006
Posts: 3
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

I get the message "To view this web content, you need to install the Java Runtime Environment" when launching the game client via steam. I only have one copy of java, the latest v7 (7.75), somehow I don't think installing 8.31 will help.

It's down to where I can only launch the game through here:
http://www.puzzlepirates.com/launch.xhtml

Anyone know what's magical about that, and why the launcher doesn't function elsewhere?
[Jan 31, 2015 9:03:29 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Runescapien

Member's Avatar


Joined: Oct 4, 2008
Posts: 74
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

Hi
I couldn't find any info on this, so I figured i'd make a post as a PSA.

If you're a patcher, do not upgrade your Java to version 8.
YPP has had issues with newer versions of Java but I think this is the most game-breaking I remember.

I came across a bug a few days ago where tokens do not count or count wrongly seemingly by random, and wasn't fixed by reinstalls of ypp or java. I eventually noticed I was on Java 8, downgraded to 7, which fixed the issue.
Someone else sent me a tell today about it, so its definitely not just me that has had this bug.

If you already upgraded to version 8, and want to token patch successfully, uninstall java 8 and install java 7 here


NOTE: AS OF 26/3 THIS BUG WAS PATCHED
----------------------------------------
Longshot of the Meridian ocean
I used to record patching
No, I don't play runescape
----------------------------------------
[Edit 1 times, last edit by Runescapien at Mar 26, 2015 2:47:56 PM]
[Mar 1, 2015 6:10:35 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
EmpressTamar

Member's Avatar


Joined: May 7, 2012
Posts: 792
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

Interesting, thanks Longshot. I'd stopped patching because of that bug--tokens didn't count properly inside atlantis and all thrall tokens were blocked inside CI (you can imagine what a mess that would be).
----------------------------------------
Empresstamar of Emerald.
Yppedia page

Gorgeous avatar by by Scythera <3
[Mar 1, 2015 8:08:55 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Maialiana

Member's Avatar


Joined: Dec 18, 2007
Posts: 505
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

I had the patch bug for a long time, and then saw the same happen on sails a week ago :/
----------------------------------------
 
XXX greeter chats, "wat is this chat for than anyway"
YYYY greeter chats, "idk its just that theres 1 rule and that we arnt alowd to chat in

[Mar 2, 2015 6:02:19 AM] Show Printable Version of Post        Send Private Message    Hai=/=Hi, Hai=Yes [Link]  Go to top 
escooper

Member's Avatar


Joined: Oct 16, 2007
Posts: 1244
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

 

Java Virtual Machine Launcher
Error: Registry key 'Software\JavaSoft\Java Runtime Environment'\CurrentVersion' has value '1.8', but '1.7' is required.

Java Virtual Machine Launcher
Error: could not find java.dll

Java Virtual Machine Launcher
Error: Could not find Java SE Runtime Enivronment



I have the same issue. How is it resolved?

Edit: I could not reinstall PP client or have it work with JE 1.8. I went to Java and got JE 1.7. Note that it is only available till April 2015! After this was back on the windows machine, I was able to reinstall PP client and have it work.
----------------------------------------
Samjones (All oceans)
Collector of ships with Mummichog fish name and Moody Adjective.

Be a pirate. Play like a pirate today #puzzlepirates
----------------------------------------
[Edit 1 times, last edit by escooper at Mar 16, 2015 2:54:58 AM]
[Mar 15, 2015 9:06:08 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Mastergreve



Joined: Jul 21, 2010
Posts: 3
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

I've downloaded java unistalled and redownloaded Java. I still get the same message when i try to download puzzle pirates. I still get the same message after " downloading control files..."UNABLE TO INSTALL: The application has failed to install due to the following error: server returned HTTP response code 503 for URL : http//download.threerings.net/yoclient/client/getdown.txt.



Please help :(
[Mar 25, 2015 12:21:10 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
jlh0605

Member's Avatar


Joined: May 1, 2007
Posts: 2239
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

 
I've downloaded java unistalled and redownloaded Java. I still get the same message when i try to download puzzle pirates. I still get the same message after " downloading control files..."UNABLE TO INSTALL: The application has failed to install due to the following error: server returned HTTP response code 503 for URL : http//download.threerings.net/yoclient/client/getdown.txt.


Did the link come missing the colon, or did you copy/paste and forget the colon? (The colon should come right after http)
----------------------------------------
~Jamesh on Emerald
Avatar by PixelPixie

Galene tells ye, "You are awesome."
[Mar 26, 2015 12:37:41 PM] Show Printable Version of Post        Send Private Message    Hidden to Guest [Link]  Go to top 
Dazicans2



Joined: Sep 21, 2010
Posts: 52
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

Hey. So I recently have had the issue that trying to play from the browser says I need to install missing plugins (Java). I found this after the client download installation failed. I updated my Java to the most recent to see if this was the error and it is still happening. While installing from the client install file, I get the error:

"We were unable to download the necessary installation files due to the following error:
HTTP/1.1 404 Not Found
This may be due to temporary network problems or a more serious error. You may try again later or we can display a web page that provides alternative installation options. Would you like to view the web page?"

This appears when the downloaded installer reaches "Downloading Java.zip".

After these issues, I decided I would see if I could run the game through Steam. This works fine and I can access the Game.

Am I the only one having this issue? Or is it common currently?

I have tried to use the full install download file. However, that currently doesn't seem to link to anything at all.

Thanks,
Spyridondaz
----------------------------------------
Spyridondaz of Emerald Ocean
[Apr 21, 2016 4:36:02 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Pewf



Joined: Apr 23, 2012
Posts: 3
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

 
"We were unable to download the necessary installation files due to the following error:
HTTP/1.1 404 Not Found
This may be due to temporary network problems or a more serious error. You may try again later or we can display a web page that provides alternative installation options. Would you like to view the web page?"


This happened to me when I had Java 8u77. I updated to Java 8u101 and it went away.
----------------------------------------
Meridian - Pewf / Zyzzyx
[Aug 3, 2016 11:06:58 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Deadtooth

Member's Avatar


Joined: Nov 10, 2016
Posts: 31
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

I would just like to reiterate that the newer versions of Java don't work with the game. So, here are the current fixes IF you are using newer versions of Java AND your game isn't working or you can't install the game.

Java version 7.x or 8.x 64-bit currently does NOT work.

Java version 7.x or 8.x 32-bit currently DOES work.

If you have both installed, and are unable to open the game or install the game, EITHER: Uninstall the Java 64-bit OR make the Java 32-bit the primary Java.

This has worked for both of my computers running different Windows OS (8.1 and 10) and different hardware.
----------------------------------------
Dreadtooth of the Emerald Ocean.

"Dying's the easy way out. You won't catch me dying. They'll have to kill me before I die!"
[Nov 15, 2016 9:59:58 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Opsat



Joined: May 20, 2007
Posts: 125
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

Hmm... getting this error again:

The application has failed to launch due to a missing resource:
http://download.threerings.net/yoclient/20160128080547/digest.txt


I've already removed all Java stuff except for the one called Java 8 Update 111 dated 10/28/2016. I also removed the 64-bit version of that.
Still getting the error. =(
What else can I do please?
----------------------------------------
Opsat on all oceans.
(Also Opsat-East on Emerald and Meridian, and Opsat-West on Cerulean.)
And on Obsidian: Opsat, Meghost, and Meshadow.
[Dec 1, 2016 6:05:42 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Gunnerfreak

Member's Avatar


Joined: Jun 12, 2011
Posts: 435
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

 
Hmm... getting this error again:

The application has failed to launch due to a missing resource:
http://download.threerings.net/yoclient/20160128080547/digest.txt


I've already removed all Java stuff except for the one called Java 8 Update 111 dated 10/28/2016. I also removed the 64-bit version of that.
Still getting the error. =(
What else can I do please?

Usually when Java makes the client want to delete the icon ye may have on yer desktop, I download the current Java version, uninstall YPP completely, and reinstall it. But there's a less time-consuming method around that Java issue. I'll have to go through my Skype chat history with someone. It's in there. I'll edit when I get it, but feel free to follow my advice for the more time-consuming method. :P
----------------------------------------
Gunnerfreak on Cerulean <- Home ocean.
AKA Gunnerfreak on Obsidian (new ocean!), Ice, Emerald, Opal, and Jade,
Gunnerfreak-East on Emerald,
Gunnerfreak-West on Cerulean, and
Gunnergunner on Meridian.
Also a Respe-ranked YPPedia-wiki freak.
[Dec 1, 2016 6:44:31 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Opsat



Joined: May 20, 2007
Posts: 125
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

Thanks so much!

I tried uninstalling and reinstalling YPP and that did the trick. =)

But if you are able to find that less time-consuming method, please do share that with us, too. Thanks again!
----------------------------------------
Opsat on all oceans.
(Also Opsat-East on Emerald and Meridian, and Opsat-West on Cerulean.)
And on Obsidian: Opsat, Meghost, and Meshadow.
[Dec 1, 2016 8:56:55 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Gunnerfreak

Member's Avatar


Joined: Jun 12, 2011
Posts: 435
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

 
Thanks so much!

I tried uninstalling and reinstalling YPP and that did the trick. =)

But if you are able to find that less time-consuming method, please do share that with us, too. Thanks again!

No problem, mate! :) Glad ye could get back on! :3
----------------------------------------
Gunnerfreak on Cerulean <- Home ocean.
AKA Gunnerfreak on Obsidian (new ocean!), Ice, Emerald, Opal, and Jade,
Gunnerfreak-East on Emerald,
Gunnerfreak-West on Cerulean, and
Gunnergunner on Meridian.
Also a Respe-ranked YPPedia-wiki freak.
[Dec 1, 2016 9:04:08 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Forevever

Member's Avatar


Joined: Jul 19, 2004
Posts: 186
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

 
Thanks so much!

I tried uninstalling and reinstalling YPP and that did the trick. =)

But if you are able to find that less time-consuming method, please do share that with us, too. Thanks again!


After running the Java updater, go to your main hard disk (usually c:) and find the file called "Program Files (x86)" (86 may not be there depending how old your pc is)

Find the folder called Java and double click it.
The next folder will give you the long version number, mine currently says "jre1.8.0_131"

Close that out - go back to your desktop and find your YPP shortcut.
Right click it and select properties

Change the version number in the url to the current version

Mine currently reads:
"C:\Program Files (x86)\Java\jre1.8.0_131\bin\javaw.exe" -jar getdown-dop.jar .

That period at the end is not a typo
----------------------------------------
Forevever and Foreverchaos
Cerulean and Meridian
----------------------------------------
[Edit 1 times, last edit by Forevever at Jul 2, 2017 8:38:15 AM]
[Jul 2, 2017 8:37:37 AM] Show Printable Version of Post        Send Private Message    forevever [Link]  Go to top 
Juliostcroix



Joined: Aug 2, 2011
Posts: 22
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

my problem is that Firefox says it does not use the Plugins for Java now. I am not computer savvy, so when I uninstall the program = which is the 32 bit, and the 64 bit? I have 2 Java Updates listed for the same day.
Java8 Update 121 53.2MB 8.0.1210.13
Java8 Update 141 54.8MB 8.0.1410.15


 
Java version 7.x or 8.x 64-bit currently does NOT work. Java version 7.x or 8.x 32-bit currently DOES work. If you have both installed, and are unable to open the game or install the game, EITHER: Uninstall the Java 64-bit OR make the Java 32-bit the primary Java.


Please advise me, thank you
[Jul 18, 2017 7:56:09 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Forevever

Member's Avatar


Joined: Jul 19, 2004
Posts: 186
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

 
my problem is that Firefox says it does not use the Plugins for Java now. I am not computer savvy, so when I uninstall the program = which is the 32 bit, and the 64 bit? I have 2 Java Updates listed for the same day.
Java8 Update 121 53.2MB 8.0.1210.13
Java8 Update 141 54.8MB 8.0.1410.15


 
Java version 7.x or 8.x 64-bit currently does NOT work. Java version 7.x or 8.x 32-bit currently DOES work. If you have both installed, and are unable to open the game or install the game, EITHER: Uninstall the Java 64-bit OR make the Java 32-bit the primary Java.


Please advise me, thank you

My suggestion would be to download the desktop client.

Here's the URL www.puzzlepirates.com/download.xhtml

This link can be found any time by clicking "Play" at the top of this (and any other ypp) page.
It's not super noticeable there, but it's under "Create your pirate" on the left, there's a short paragraph explaining how to give permissions. At the end of that paragraph is a link to download the client directly to your desktop.

I have always played with the desktop client so I can't be sure - but I do know that Firefox made a lot of changes in the last year to how they handle plugins - and this is most likely the cause of your issues.
----------------------------------------
Forevever and Foreverchaos
Cerulean and Meridian
----------------------------------------
[Edit 1 times, last edit by Forevever at Jul 20, 2017 8:26:51 AM]
[Jul 20, 2017 8:26:17 AM] Show Printable Version of Post        Send Private Message    forevever [Link]  Go to top 
Barneygk



Joined: Jul 28, 2017
Posts: 2
Status: Offline

Re: Update your Java installation today! Reply to this Post
Reply with Quote

My game wont start. It says--
Missing jar file
Please help anyone asap.
[Aug 27, 2017 7:56:37 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Odyn9

Member's Avatar


Joined: Jul 23, 2017
Posts: 39
Status: Offline
Re: Update your Java installation today! Reply to this Post
Reply with Quote

 
My game wont start. It says--
Missing jar file
Please help anyone asap.


Even if you have a 64 bit operating system download the 32 bit version of Java as well. I was unable to use anything except the steam client until I tried that one morning and it worked.
----------------------------------------
Zaye - Emerald
Odyn - Obsidian

Captain of the crew Era

avatar by Cattrin
[Aug 27, 2017 10:09:40 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Posts: 83   Pages: 3   [ First Page | Previous Page | 1 2 3 | Last Page]
[Show Printable Version of Thread] [Post new Thread]

Puzzle Pirates™ © 2001-2016 Grey Havens, LLC All Rights Reserved.   Terms · Privacy · Affiliates