• Play
  • About
  • News
  • Forums
  • Yppedia
  • Help
Welcome Guest   | Login
  Index  | Recent Threads  | Register  | Search  | Help  | RSS feeds  | View Unanswered Threads  
  Search  


Quick Go »
Thread Status: Normal
Total posts in this thread: 12
[Add To My Favorites] [Watch this Thread] [Post new Thread]
Author
Previous Thread This topic has been viewed 6260 times and has 11 replies Next Thread
Vurogj

Member's Avatar


Joined: Jul 28, 2003
Posts: 2233
Status: Offline
[critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

Who wants to tell me what's wrong with this screen?



I tried washing out the guns jes' to make sure they hadn't been fired wi'out showin' me, no effect, so I had to quit and restart.

Didn't think to /bug it until after battle, and figured it would have been too late by then anyway. I'll try and remember fer when it happens again.
----------------------------------------
Older, crankier,
still haz da phat haiku skillz.
Tawnee on Midnight.
Avatar from roflrazzi.com
Apollo says, "Tawnee, I should have known you were involved."
[Mar 24, 2005 3:17:55 AM] Show Printable Version of Post        Send Private Message    vurogj    vurojg [Link]  Go to top 
Lizthegrey
Developer (retired)
Member's Avatar


Joined: Jul 22, 2004
Posts: 6912
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

It's never too late to file a /bug as long as you haven't quit and restarted the client.
[Mar 24, 2005 7:29:11 AM] Show Printable Version of Post        Send Private Message    https://plus.google.com/106912596786226524817/posts [Link]  Go to top 
Lizthegrey
Developer (retired)
Member's Avatar


Joined: Jul 22, 2004
Posts: 6912
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

Inuki tells you, "Got a crewmate who says he's on a gun mission but is getting all the guns loaded when he enters the puzzle. Told him to /tell Mnem - any other thoughts?"

Seems guns are getting stuck in the faux-"Loaded" state. I was unable to reproduce, even if I hopped on the same ship. Bug reported by Padman.
[Mar 24, 2005 1:26:54 PM] Show Printable Version of Post        Send Private Message    https://plus.google.com/106912596786226524817/posts [Link]  Go to top 
drc500free

Member's Avatar


Joined: Aug 27, 2004
Posts: 5277
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

I don't believe this is a bug. Guns have been changed from First-In, Last-Out to First-In, First-Out. If you are on anything above a sloop, that means that the 4 cannons you just filled will be the last to be fired. If you reload the board, you will get the older, fired cannons.

Granted this new feature could actually be a bug... it certainly is annoying.
----------------------------------------
-Darvid
sundancer wrote: 
will you please explain to me one more time why it would not be acceptable to blockade us?
Squid wrote: 
Because I shouldn't have to go through all that effort.

[Mar 25, 2005 5:32:01 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Lizthegrey
Developer (retired)
Member's Avatar


Joined: Jul 22, 2004
Posts: 6912
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

Look at the display again. Bnav shows 1 cannon loaded. 4 cannons are "loaded" on the screen.

And the greenie reporting the issue on Viridian was on a Navy ship, and the guns appeared to be loaded.
[Mar 25, 2005 5:33:50 AM] Show Printable Version of Post        Send Private Message    https://plus.google.com/106912596786226524817/posts [Link]  Go to top 
Inuki

Member's Avatar


Joined: Apr 19, 2004
Posts: 740
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

Perhaps a bit late to the discussion...

This has happened to me as well, in the past. Enter the puzzle, guns appear to fire, but loading them then leads to nothing happening: no update in the nav counter, and no additional firing. Duty report scores a booched, if you don't ditch and get something else done.

Conventional wisdom (read: what other said when I griped at them) says that it's best to just ditch and re-enter if you ever think you're booched like that.

I suspect taking it a little slower when abandoning repeatedly would help prevent it. I did track it down one time in yohoho.log, and believe that it was supposed to throw the "station is manned" error - so the server didn't see you enter the board, but the client gave you one anyway, and that's where the mismatch is.

Other preventative thoughts - when loading a gun, if you've time, check the little counter to make sure that yes, you're actually affecting it. If the server's counting it correctly, you're not booched.
----------------------------------------
Now in a special Hunter flavor.
[Mar 28, 2005 1:35:58 PM] Show Printable Version of Post        Send Private Message    inuki42    Inuki42 [Link]  Go to top 
starrarose

Member's Avatar


Joined: Aug 23, 2004
Posts: 6123
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

Funny I was taking a trainee out and he said that his screen - the bat nav screen - was showing no guns, but my smaller version was showing all loaded, I was gunning. I dropped out of the gun board, took over Bat Nav, fired the lot of them and everything worked fine from there (apart from said trainee sucking at Bat Nav but oh well, that's a player issue) Now that I know this is an issue I'll tell them to bug it if it happens again.

Interesting that the Bat Nav screen said no guns for 3 turns but the gunnery mini screen showed the numbers rotating as I loaded....
----------------------------------------
Phoenix - Black Plague to the core, Flag may change randomly.

Prometheus wrote: 
TheRack wrote: 

I think the OM's suck and are cheats.

no u

-Pro

[Mar 30, 2005 1:56:20 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
trent121212



Joined: Jan 5, 2006
Posts: 3
Status: Offline

Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

lol
[Jan 22, 2006 8:27:23 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
AtheneNoctua

Member's Avatar


Joined: Dec 3, 2005
Posts: 3628
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

Please don't bump old threads for no reason.
----------------------------------------
                                                     
[Jan 22, 2006 8:47:54 AM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
imwamphyr

Member's Avatar


Joined: Aug 29, 2004
Posts: 7641
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

Actually, this bug hit me the other day for the first time. I thought it had long ago been fixed, and that bug reports had been sent in dozens of times, so no, I didn't add another one.

Are we still having problems documenting it? Since it's only hit me the one time, I imagine it will never hit me again. If it does, I guess I won't assume crap anymore and I'll send a report.
----------------------------------------
Selling my Grunion Collection!
174 ships, 164 sloops, ALL GRUNIONS!
[Jan 22, 2006 5:51:11 PM] Show Printable Version of Post        Send Private Message    Pirate Muroni [Link]  Go to top 
emerson

Member's Avatar


Joined: Aug 4, 2003
Posts: 8878
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

I've had it hit me 3-4 times, so don't assume you'll never see it again.
----------------------------------------
Cleaver shouts, "I lub this island."
Personally I think that TITS are a technique if they are used less than once every three moves. Any more than that, and you're just waving your exploits in their faces. - Flamer
[Jan 22, 2006 8:09:53 PM] Show Printable Version of Post        Send Private Message [Link]  Go to top 
Lizthegrey
Developer (retired)
Member's Avatar


Joined: Jul 22, 2004
Posts: 6912
Status: Offline
Re: [critical] Problem wi' guns not firing, despite being fired. Reply to this Post
Reply with Quote

Still having problems with gunnery out of sync, it's on the list of bugfixes to be done after we finish this release cycle of new content.
[Jan 22, 2006 8:22:33 PM] Show Printable Version of Post        Send Private Message    https://plus.google.com/106912596786226524817/posts [Link]  Go to top 
[Show Printable Version of Thread] [Post new Thread]

Puzzle Pirates™ © 2001-2016 Grey Havens, LLC All Rights Reserved.   Terms · Privacy · Affiliates